You are not logged in.

Search results

Search results 1-20 of 21.

Thursday, January 29th 2015, 2:22pm

Author: Tngrl423

Please Welcome the Brazilian Community!

Quoted from "IAmGroot" Sup noobs. Quoted from "IAmGroot" As a joining fee, of coming to our server, you must each mail IAmGroot 50,000 gold. Quoted from "IAmGroot" Thanks and happy gaming! Quoted from "IAmGroot" Sup noobs. As a joining fee, of coming to our server, you must each mail IAmGroot 50,000 gold. Thanks and happy gaming! LOLOL

Thursday, March 27th 2014, 11:05am

Author: Tngrl423

Maintance downtime 27/03/14

Quoted from "Wraith02" Hi Tngrl423, As bloodraven said, the servers are still down for maintenance so I believe that is why you are getting that message at this time. -Wraith I was having this problem even before maintenance. Like I said I haven't been able to use the launcher at all without getting that message.

Thursday, March 27th 2014, 10:56am

Author: Tngrl423

Astral Servant

Quoted from "Mrbates" what zone are you in, bc I had an issue with it but it just involved turning my flag on nothing major. Could also be the antivirus; but shouldn't be an issue with interacting if you can see it. Was your ping anything but green? Because if it was yellow game might just be saying oh you're too far away without actually notifying you. Heya Bates No, my ping was green and I was in YT in my corner where I'm always at and I seen it summon then it disappeared~ Never happened befo...

Thursday, March 27th 2014, 10:45am

Author: Tngrl423

Maintance downtime 27/03/14

Quoted from "Kaggon" Quoted from "Zhankou" Lets hope the UI gets saved now after maintenance. This is a very anoying BUG. C:/mygames/allods/bin/launcher.exe Will solve everything. There has been a post on it for the last week. But that will help you. Just make sure you dont run the program from the my.com launcher!! I can only play the game through My.com...when I bring up the launcher it tells me "An error occurred while trying to connect to the server Error 2.8 Please make sure that your inte...

Wednesday, March 26th 2014, 11:26pm

Author: Tngrl423

Astral Servant

I'll try that thanks

Wednesday, March 26th 2014, 3:43am

Author: Tngrl423

Astral Servant

I know how a goblin banker works...

Tuesday, March 25th 2014, 6:31pm

Author: Tngrl423

Astral Servant

Yes, I have the 10 min debuff. I can not interact with it whatsoever, but I'm able to see others.

Tuesday, March 25th 2014, 5:12pm

Author: Tngrl423

Astral Servant

Every time I summon my servant (yes it is perm) then it disappears/ Is anybody else having this issue. Mine just started today and I don't understand what is going on.

Monday, March 24th 2014, 12:59pm

Author: Tngrl423

Lf endgame guild.

Lol Omni hihi

Saturday, March 22nd 2014, 12:15am

Author: Tngrl423

Frustrated

okays xD

Friday, March 21st 2014, 11:49pm

Author: Tngrl423

Frustrated

nuuu don't make new toon

Friday, March 21st 2014, 11:23pm

Author: Tngrl423

Frustrated

Lol Cyn xD

Friday, March 21st 2014, 11:15pm

Author: Tngrl423

Frustrated

Right, but its just a waiting game now I had also done the in-game thing also. It will be resolved soon enough and then we can play again xD

Friday, March 21st 2014, 11:01pm

Author: Tngrl423

Frustrated

Miserable..no. Just wanta know that my toons are safe and I don't have to start all over again. I know they are in the database just hope I didn't do nothing wrong in the process of the account transfer. I have the patience to wait, but I don't want to

Friday, March 21st 2014, 10:52pm

Author: Tngrl423

Frustrated

Waiting sure why not only been waiting since Monday a few more days, weeks, and months won't hurt nothing. Then by that time I can just forget about Allods

Friday, March 21st 2014, 10:42pm

Author: Tngrl423

Frustrated

Already have

Friday, March 21st 2014, 10:31pm

Author: Tngrl423

Picture Thread!

Queeenie - Bard - Disturbed