You are not logged in.

Dear visitor, welcome to Allods Online Forum. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

61

Friday, February 24th 2017, 7:21am

Still happening, still no update from support...

62

Saturday, February 25th 2017, 1:36am

Hello,

Unfortunately, we don't have additional information about this lag issue, other than what the support team already answered to players that sent a ticket :/.
Allods Online Discord
Check out the community chat
----
Rejoignez la communauté sur le serveur Discord Allods Online

63

Saturday, February 25th 2017, 7:42am

Truthfully, support hasn't been particularly communicative either. I'm not expecting a miracle fix, but some kind of status update other than "our development team is still investigating this issue" would be nice. Like maybe the things they've looked, things they've ruled out, things that could potentially be the problem. Something.

64

Saturday, February 25th 2017, 12:37pm

Most likely the cause of the problem is hardware. Russian servers have significantly more players (yes, on individual servers too) and only thing they ever complained about was Arena of Death.

It's clear that International version is being run with bare minimum investment. It's reflected in pretty much every aspect of it.

65

Saturday, February 25th 2017, 7:41pm

if it were hardwarerelated only, how can it be not all players are affected?

its like with the weird lag-issues the game had / still has for some players

66

Saturday, February 25th 2017, 8:18pm

if it were hardwarerelated only, how can it be not all players are affected?

And aren't all of them affected?

67

Saturday, February 25th 2017, 8:39pm

68

Saturday, February 25th 2017, 10:08pm

The last time there was a big issue like this (for me anyway) it was because they screwed up driver optimization in the client for ATI or nVidia, I don't remember which.

Rate this thread