You are not logged in.

Dear visitor, welcome to Allods Online Forum. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

1

Thursday, March 28th 2019, 8:18am

Ping suddenly unplayable

Hi everyone,
I have always played on a laptop, over wlan, and I never experienced big problems.

For a few days now, my ping is out of control, to the point I can't play anymore. I've had disconnects and had to wait nearly a minute for certain interactions to complete (looting, taking quests, ...), fighting is impossible (at least in KoE, where I tried).

Is this a problem anyone else is experiencing? I have no deeper understanding of the games client/server function, and the problem could be only on my side.

Several online-connection tests haven't found I have a very high ping, though.
Playing from germany, by the way.
Please answer, maybe a fix is on its way?
Best Regards

2

Thursday, March 28th 2019, 10:32am

Aionwen

Intermediate

Posts: 503

Location: Berlin

  • Send private message

"maybe a fix is on its way" XDXDXDXD

THE PROBLEM will be definitly on YOUR side... whatever its origin is XDXDXD
PLS make Tekians playable race. fix shipcanons!

3

Thursday, March 28th 2019, 10:46am

Update:
Seems to be an on-off-problem, at the moment, everything works fine, ping indicator is leaf-green...

Rate this thread