You are not logged in.

Dear visitor, welcome to Allods Online Forum. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

1

Monday, December 22nd 2014, 6:21pm

paid for crystals i did not recieve

I have made an error it seems, yet it's been 7 days and not heard a word from anyone, I am about to dispute this with my bank. I never had a problem with it before, but did not play this game in quite a while. Did not know I had to basically link 3 accounts together before I made a transaction, well, gpotato allods online with webzen, then my.com with allods or whatever. I tried to buy 900 crystals for a mount on the 16th of this month and nothing happened. I did have an account with my.com already, with the same email address and what not from the game. I did not verify the account, I tried, even before the transaction, wasn't able to, then I tried after the transaction, took a few tries, but was was able to. I have opened a ticket of course, and even responded to it last night, but nothing. Everyone told me good luck with that, would take weeks if you are lucky. and I said, why would it take weeks, when I paid for a service....but hopefully I can get some help through here, as I seen gm's come in and read in the forums more often I guess. I just want my mount I paid to get my crystals with that did not come through...

2

Monday, December 22nd 2014, 7:18pm

Posts: 342

Location: Lyon

Occupation: Modérateur FR

  • Send private message

Hello deary,
You asked that you've linked 3 accounts together? With the same mail account or not?
If you used 3 differents mails try to connect one time on each account and see if cristals are here.
Otherway you might contact Mhuldoon dirrectly if you still have problems but i dont think that he can do more things... he'll probably launch the support again :/.

/!\ Attention: Utiliser les services des goldsellers peut mener à un ban permanent /!\

3

Wednesday, December 24th 2014, 6:04am

I am confused...I had gpotato to begin with on a different email adrdress. well, I basically started a new account. using a different email address. that email address is used on webzen, allods when I log in.. and my.com.

4

Wednesday, December 24th 2014, 6:05am

something is not happenin, all I know, lol

5

Wednesday, December 24th 2014, 6:07am

I bought 900 on the 16th, used my bank card, now today, I tried it again, same bank card, but through paypal, same result. gave them my transcation id number from paypal, and first 6 numbers and last 4 from my bank card.

6

Wednesday, December 24th 2014, 6:08am

and how do I contact Mhuldoon directly?

7

Wednesday, December 24th 2014, 6:58am

Kurtcobain

Professional

Posts: 701

Location: in my Livingroom

Occupation: Geriatric nurse

  • Send private message

Hello

You can reach Mhuldoon here in the forum directly by write him a Personal Message. Just look at the Team Member Section in the Member Section and you will find him to wrote him a Personal Message.

But im a little bit confused, about that e-mail thing. Maybe you have load the Cristals to a E-Mail that not linked with your Chars?
Kurtcobain-Lvl 80-Demo/ Sechmet-Lvl 80 Cleric

KurtCobain - lvl 80 Cleric (LEAGUE)



8

Wednesday, December 24th 2014, 7:23am

haa, well, figured it out..the thing is, I bought another 900 today, used my bank card, through paypal this time, it went through to the account I wanted. I went to my email account, verified it, and saved my info, then it deleted the character I had made last week, but I got my crystals I paid for today. The thing is, when I used my bank card directly, they cannot find the transaction, but it's right on my statement. The card is from my work, not my bank acct. so that might be an issue, but again, it's right on my bank statement from the 16th, didn't go through till the 17th.

9

Wednesday, December 24th 2014, 7:25am

thought I did the whole verification thing when I created that account. have a much older account when I had gone through gpotato, wonder if I figured that out to get my old character back from that. and thanks for the help. reading your response from the first one a few times, made something click in my head a little, lol

Rate this thread